Задать вопрос
19 января, 04:42

Хелп! ...

Составить программу если число положительное, извлечь квадратный корень, в другом случае взвести в квадрат.

+4
Ответы (1)
  1. 19 января, 07:12
    0
    Program z123;

    var a:real;

    begin

    readln (a) ; / / Вводим число

    If a>0 then / / Проверяем

    a:=Sqrt (a) / / Вычиляем

    else

    a:=Sqr (a) ; / / Вычисляем

    writeln (a) ; / / Выводим

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Хелп! ... Составить программу если число положительное, извлечь квадратный корень, в другом случае взвести в квадрат. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы