Задать вопрос
20 мая, 02:47

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

+5
Ответы (1)
  1. 20 мая, 06:19
    0
    Const

    n = 40;

    var

    x: array[1 ... n] of integer;

    i, k, s: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    k : = 0; s : = 0;

    for i : = 1 to n do

    begin

    x[i] : = Random (50) ;

    Write (x[i]:3) ;

    end;

    Writeln;

    Writeln ('Элементы со значением в интервале [7; 10]') ;

    for i : = 1 to n do

    if (x[i] > = 7) and (x[i] < = 10) then

    begin

    k : = k + 1; s : = s + x[i];

    Write (x[i]:3)

    end;

    if k = 0 then Writeln ('не найдены')

    else Writeln (#13#10, ' Элементов:', k, ', среднее арифметическое=', s / k:5:3)

    end.

    Тестовое решение:

    Элементы массива

    24 33 36 29 12 7 5 36 3 48 40 40 46 6 10 23 33 3 38 48 29 37 11 40 44 16 17 18 34 38 33 39 9 0 41 37 42 2 40 31

    Элементы со значением в интервале [7; 10]

    7 10 9

    Элементов: 3, среднее арифметическое=8.667
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы