Задать вопрос
30 марта, 00:17

Написать программу, которая генерирует 10 четных чисел и сортирует их по возрастанию.

Точного промежутка чисел в условии нет, но я думаю, можно поставить свое - например, 100

+1
Ответы (1)
  1. 30 марта, 04:24
    0
    Type

    arr = array[1 ... 10] of integer;

    const / / числа, которые генерируются (от 0 до d-1)

    d = 101;

    var / / массив, хранящий сгенерированные числа

    a: arr;

    procedure Sort (var arg: arr) ; / / сортирует массив по возрастанию

    var

    t: integer;

    begin

    for var i : = 1 to 9 do

    for var j : = 1 to 9 do

    if arg[j] > arg[j + 1] then begin

    t : = arg[j];

    arg[j] : = arg[j + 1];

    arg[j + 1] : = t;

    end;

    end;

    begin

    randomize () ;

    for var i : = 1 to 10 do a[i] : = Random (d) ; / / генерация рандомных чисел (0 ... d-1)

    Sort (a) ; / / сортировка массива

    for var i : = 1 to 10 do write (a[i], ' ') ; / / вывод массива

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая генерирует 10 четных чисел и сортирует их по возрастанию. Точного промежутка чисел в условии нет, но я думаю, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы