Задать вопрос
22 сентября, 15:35

Задание по ИКТ! Составить программу с пояснениями! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их сумму. В паскале а если еще можно то блок схему)

+4
Ответы (1)
  1. 22 сентября, 16:11
    0
    Program mas;

    const n=4; / / число элементов

    var a: array [1 ... n] of integer; / / массив

    i, sum: integer; / / переменные

    begin / / начало

    sum:=0; / / сумма=0

    for i:=1 to n do readln (a[i]) ; / / вводим массив

    for i:=1 to n do / / цикл

    if (a[i] mod 2 0) then / / условие нечетности

    begin

    writeln (a[i]) ; / / выводим нечетные

    sum:=sum+a[i]; / / считаем сумму

    end;

    writeln (sum) ; / / выводим сумму

    end. / / конец
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задание по ИКТ! Составить программу с пояснениями! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы