Задать вопрос
3 апреля, 22:16

Сложное задание по информатике:

Нужно написать программу на паскале, не используя if, then, else, с таким результатом:

Введите число

если число четное, то вывести 10;

если нечетное, то вывести - 10

+4
Ответы (2)
  1. 3 апреля, 23:32
    0
    Var

    n: integer;

    res: boolean;

    begin

    readln (n) ;

    res:=odd (n) ;

    case res of

    true: writeln ('-10') ;

    false: writeln ('10') ;

    end;

    end.
  2. 3 апреля, 23:42
    0
    Var a:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    writeln (-20 * (abs (a) mod 2) + 10) ;

    end.

    Пример:

    a = 28

    10
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сложное задание по информатике: Нужно написать программу на паскале, не используя if, then, else, с таким результатом: Введите число если ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы