Задать вопрос
2 января, 05:13

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты. Результат выводится в строку.

+1
Ответы (1)
  1. 2 января, 08:46
    0
    var

    a:array[1 ... 5]of integer;

    i:integer;

    begin

    for i:=1 to 5 do read (a[i]) ;

    for i:=1 to 5 do write (a[i],' ') ;

    writeln;

    for i:=1 to 5 do if a[i]>=1024 then writeln (a[i] div 1024) ;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы