Задать вопрос
14 июня, 09:46

6. Составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых N произвольных (как положительных, так и отрицательных) целых чисел. N не больше 10

+1
Ответы (1)
  1. 14 июня, 11:13
    0
    Var a:array[1 ... 100] of integer;

    i, n, s, k:integer;

    begin

    s:=0; k:=0;

    write ('Введите кол-во чисел: ') ; readln (n) ;

    write ('Введите числа: ') ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    if a[i]<0 then begin

    s:=s+a[i];

    inc (k) ;

    end;

    if k0 then

    begin writeln ('Ср. знач. отрицательных чисел: ', s/k) ;

    writeln ('Сумма отрицательных чисел: ', s) ; end

    else writeln ('Отрицательных членов нет') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «6. Составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых N произвольных (как ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы