Задать вопрос
15 июня, 00:52

Помогите составить программу в Pascal!

Задана последовательность слов. Определить частоту вхождения каждого из слов в последовательность.

+4
Ответы (1)
  1. 15 июня, 01:40
    0
    Var s, r, k: string;

    j: integer;

    begin

    write ('строка: ') ; readln (s) ;

    foreach k in s. Split (' '). Distinct do

    begin

    j:=0;

    foreach r in s. Split (' ') do

    if r=k then j:=j+1;

    writeln ('слово ','"', k,'"',' встречается ', j,' раз') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу в Pascal! Задана последовательность слов. Определить частоту вхождения каждого из слов в последовательность. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы