Задать вопрос
29 мая, 20:54

Знак числа (C++).

Для данного числа x выведите значение sign (x). Например, при x=179 программа должна вывести 1.

Формат входных данных:

В программу вводится вещественное число x (-100000 ≤ x ≤ 100000), заданное с двумя знаками после десятичной точки.

Формат выходных данных:

Программа должна вывести - 1, 0 или 1.

+4
Ответы (1)
  1. 30 мая, 00:04
    0
    Int main ()

    {

    int x;

    std::cin >>x;

    if x>0 std::cout << "1" else

    if x<0 std::cout << "-1" else

    std::cout << "0";

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Знак числа (C++). Для данного числа x выведите значение sign (x). Например, при x=179 программа должна вывести 1. Формат входных данных: В ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы