Задать вопрос
27 августа, 05:08

Описать функцию Sign (X) целого типа, возвращающую для вещественного числа X следующие значения: 6 - 1, если X 0. С помощью этой функции найти значение выражения Sign (A) + Sign (B) для данных вещественных чисел A и B.

+2
Ответы (1)
  1. 27 августа, 06:43
    0
    Function Sign (x:real) : integer;

    begin

    if x<0 then Sign:=-1

    else if x=0 then Sign:=0

    else Sign:=1;

    end;

    var a, b:real;

    begin

    writeln ('a, b:') ;

    readln (a, b) ;

    writeln ('Sign (A) + Sign (B) = ', Sign (a) + Sign (b)) ;

    end.

    Пример:

    a, b:

    -8 0

    Sign (A) + Sign (B) = - 1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Описать функцию Sign (X) целого типа, возвращающую для вещественного числа X следующие значения: 6 - 1, если X 0. С помощью этой функции ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Описать массив А который состоит из 14 элементов вещественного типа, нумерация начинаеться с 1 Описать массив f который состоит из 16 элементов вещественного типа, нумерация начинается с 1
Ответы (1)
В математике функция sign (x) (знак числа) определена так: sign (x) = 1, если x > 0, sign (x) = - 1, если x < 0, sign (x) = 0, если x = 0. Для данного числа x выведите значение sign (x). Ввод 179 Вывод 1
Ответы (1)
Помогите решить задачи по паскалю 1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y) Используя функцию sign (x) = - 1 если x0 2. Написать процедуру для нахождения степени числа и вычислить значение выражения:x^5+x^4+x^8 3.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)