Задать вопрос
20 июля, 04:50

А) Составьте программу ввода элементов массива а[1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями.

б) составьте программу, которая заполняет массив b[1 ... 8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечетными значениями.

+3
Ответы (1)
  1. 20 июля, 08:21
    0
    А)

    var a:array[1 ... 8] of integer;

    i:integer;

    begin

    for i:=1 to 8 do read (a[i]) ;

    for i:=1 to 8 do if (a[i] <0) then writeln (a[i]) ;

    end.

    б)

    var b:array[1 ... 8] of integer;

    i, c:integer;

    begin

    rand omize;

    for i:=1 to 8 do begin

    b[i]:=random (10) + 1;

    if (b[i] mod 2=1) then inc (c) ;

    end;

    writeln (c) ;

    end.

    Не забывай отмечать лучший ответ!
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «А) Составьте программу ввода элементов массива а[1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. б) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы