Задать вопрос
6 августа, 11:03

Найти значение функции y=√ (x-1) / (sin 1/x) в промежутке [1.2; 2] с шагом 0.1

+1
Ответы (1)
  1. 6 августа, 12:01
    0
    Const a=1.2; b=2; h=0.1;

    var x, y:real; n, i:integer;

    begin

    x:=a-h;

    n:=round ((b-a) / h) + 1;

    writeln (' № x y') ;

    for i:=1 to n do

    begin

    x:=x+h;

    y:=sqrt ((x-1) / sin (1/x)) ;

    writeln (i:2,' ', x:3:1,' ', y:8:4) ;

    end;

    end.

    Результат:

    № x y

    1 1.2 0.5198

    2 1.3 0.6567

    3 1.4 0.7814

    4 1.5 0.8992

    5 1.6 1.0127

    6 1.7 1.1232

    7 1.8 1.2316

    8 1.9 1.3385

    9 2.0 1.4442
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти значение функции y=√ (x-1) / (sin 1/x) в промежутке [1.2; 2] с шагом 0.1 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Записать в виде обычной математической формулы 1) y:=2*sin (x) * sqrt (x+sqrt (abs (x))) 2) y: = sqrt (sin (x) + sin (sqrt (x))) 3) y: = sqrt (abs (x-1) + sqrt (sin (x))) 4) y: = (5*sin (x) + 4) / 2*15*sin (sqrt (x)) 5) k+15*x / (2*sin (x)) 6) y:=
Ответы (1)
2. Протабулируйте функцию у = xsin2x на промежутке [-2; 2] с шагом 0,2 и вычислите среднее арифметическое отрицательных значений. 3. Найти все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. 4.
Ответы (1)
Протабулировать заданную функцию y=f (x) на промежутке [3.2, 3.9] с постоянным шагом h=0.1. Функция y (x) имеет вид: (x-1) ^sin (x), если ctan (x) > - 0.1 (x+1) ^sin (x), если ctan (x) < = - 0.1
Ответы (1)
В паскале в 3 циклах: for; repeat; white. Вычислить и напечатать значения функции и соответствующие им значения аргументов x, y. z=2xy-2yx при изменении первого аргумента x[-1; 1] с шагом 0.1 и второго аргумента y[2; 2] с шагом 0.2.
Ответы (1)