Задать вопрос
26 августа, 10:39

Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале

+4
Ответы (1)
  1. 26 августа, 13:08
    0
    Var

    n:longint;

    i, s, p, y:integer;

    t:string;

    x:real;

    begin

    write ('Введите число: ') ;

    readln (n) ;

    p:=1;

    t:=IntToStr (n) ;

    for i:=1 to length (t) do

    begin

    y:=StrToInt (t[i]) ;

    if y>1 then

    begin

    s:=s+1;

    p:=p*y

    end;

    end;

    x:=exp (ln (p) / s) ;

    writeln ('Среднее геом. цифр больших единицы: ', x)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы