Задать вопрос
16 июля, 01:16

Составить программу в паскале, которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных.

+2
Ответы (1)
  1. 16 июля, 05:11
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, s, k:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) - 25;

    write (a[i]:4) ;

    end;

    writeln;

    s:=0; k:=0;

    for i:=1 to n do

    if a[i]<0 then begin s:=s+a[i]; k:=k+1; end;

    writeln ('s = ', s,' k = ', k) ;

    if k>0

    then writeln ('Среднее арифметическое отрицательных = ', s/k)

    else writeln ('Отрицательных нет') ;

    end.

    Пример:

    Массив A:

    -11 11 13 9 - 11 - 2 18 - 18 3 - 14

    s = - 56 k = 5

    Среднее арифметическое отрицательных = - 11.2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в паскале, которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы