Задать вопрос
21 октября, 08:35

Вводится массив, состоящий из целых чисел. Найти наибольшее среди них.

Входные данные

Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.

Выходные данные

Необходимо вывести значение наибольшего элемента в массиве.

Примеры

Входные данные

3

1 2 3

Выходные данные

3

+1
Ответы (1)
  1. 21 октября, 10:57
    0
    Var

    a:array[1 ... 35]of integer;

    i, max, n:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    read (a[i]) ;

    max:=a[1];

    for i:=1 to n do

    if a[i]>max then

    max:=a[i];

    writeln;

    writeln (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы