Задать вопрос
7 апреля, 09:10

Дан массив вещественных чисел. Каждый отрицательный элемент заменить на его абсолютную величину

+1
Ответы (1)
  1. 7 апреля, 10:46
    0
    Uses crt;

    var i, n:integer;

    a:array[1 ... 100] of real;

    begin

    writeln ('Сколько чисел в массиве?') ;

    read (n) ;

    writeln ('Введите элементы.') ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if a[i]<0 then

    a[i]:=abs (a[i]) ;

    end;

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив вещественных чисел. Каждый отрицательный элемент заменить на его абсолютную величину ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы