Задать вопрос
26 октября, 07:22

Даны первый член и разность арифметической прогрессии. Написать рекурсивную процедуру для нахождения

$n$-го члена прогрессии и суммы первых $n$ членов.

Формат входных данных

В первой строке входного файла содержатся 3 целых числа $n$, $1 / le n / le 100$, первый член прогрессии

$a_1$, $/mid a_1 / mid / leq 100$ и разность прогрессии $d$, $/mid d / mid / leq 100$.

Формат выходных данных

Выходной файл должен содержать два числа - $n$-й член прогрессии и сумму первых $n$ членов.

Примеры:

Вход

5 34 - 2

Выход

26 150

+3
Ответы (1)
  1. 26 октября, 10:21
    0
    Var n, a1, d, an, s:integer;

    procedure p (n, a1, d:integer; var an, s:integer) ;

    begin

    if n>1

    then begin p (n-1, a1, d, an, s) ; an:=an+d; s:=s+an; end

    else begin an:=a1; s:=a1; end;

    end;

    begin

    writeln ('n, a1, d:') ;

    readln (n, a1, d) ;

    p (n, a1, d, an, s) ;

    writeln ('an = ', an,' s = ', s) ;

    end.

    Пример:

    n, a1, d:

    5 34 - 2

    an = 26 s = 150
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны первый член и разность арифметической прогрессии. Написать рекурсивную процедуру для нахождения $n$-го члена прогрессии и суммы первых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы