Задать вопрос
31 декабря, 11:38

Не могу составить программу, уже весь мозг перевернул, помогите через Pascal

Присвоить целой переменной d четвертую от конца цифру в записи

положительного целого числа x (например, если x=34517, то d=4)

+2
Ответы (1)
  1. 31 декабря, 15:00
    0
    Program Project;

    uses

    crt;

    var

    x, d: integer;

    begin

    clrscr;

    write ('x=') ;

    readln (x) ;

    d: = (x div 1000) mod 10;

    writeln ('d=', d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Не могу составить программу, уже весь мозг перевернул, помогите через Pascal Присвоить целой переменной d четвертую от конца цифру в записи ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы