Задать вопрос
16 февраля, 21:45

На паскале написать программу которая в последовательность чисел (натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. Программа получает на вход нат числа, признаком окончания ввода явл число 0.

Могу решить и сам, только нельзя на компе проверить. Так что надеюсь на вас.

+4
Ответы (1)
  1. 16 февраля, 23:05
    0
    Var

    a: integer;

    s: longint;

    begin

    s : = 0;

    a : = - 32768;

    while a 0 do

    begin

    readln (a) ;

    if a 0 then

    if a mod 4 = 0 then

    if a mod 10 = 6 then s : = s + a

    end;

    writeln ('Сумма равна ', s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На паскале написать программу которая в последовательность чисел (натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы