Задать вопрос
5 января, 17:53

Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда.

+4
Ответы (1)
  1. 5 января, 19:21
    0
    Программа получает на вход N, почле чего в цикле постепенно обрабатывает все натуральные числа от 1 до N включительно и в ячейку памяти s откладывает их квадраты.

    program summa;

    uses crt;

    var N, a, s, i: integer;

    begin

    read (N) ; a:=0; s:=0;

    for i:=1 to N do

    begin

    a:=a+1;

    s:=s + (a*a) ;

    end;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать алгоритм и составить программу для вычисления суммы квадратов первых N членов натурального ряда. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы