Задать вопрос
16 сентября, 03:14

Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year - для хранения года и month - для месяца. Пользователь вводит год и месяц. 8 Оператор выбора case по номеру месяца определяет количество дней в нем. Ситуация осложняется тем, что в феврале может быть как 28 дней, так и 29 (в високосный год). Год является високосным, если делится без остатка на 4 и при этом не является последним годом столетия, за исключением того столетия, которое без остатка делится на 400.

+1
Ответы (1)
  1. 16 сентября, 04:07
    0
    Type

    data = record

    year:integer;

    month:byte;

    End;

    Var

    d:data;

    Begin

    Write ('Год: ') ; ReadLn (d. year) ;

    Write ('Месяц: ') ; ReadLn (d. month) ;

    Write ('Количество дней в этом месяце: ') ;

    Case d. month of

    1,3,5,7,8,10,12:WriteLn (31) ;

    4,6,9,11:WriteLn (30) ;

    2:if (d. year mod 4 = 0) and ((d. year mod 100 0) or (d. year mod 400 = 0)) then WriteLn (29)

    else WriteLn (28)

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы