Задать вопрос
18 апреля, 19:17

Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных к 3 (for)

+5
Ответы (1)
  1. 18 апреля, 20:27
    0
    var

    i, s, p : integer;

    begin

    write ('n=') ;

    readln (n) ;

    s:=0;

    p:=1;

    for i:=1 to n do

    begin

    if i mod 5=0 then s:=s+i;

    if i mod 3=0 then p:=p*i

    end;

    Writeln ('s=', s, ' p=', p)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных к 3 (for) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы