Задать вопрос
26 февраля, 15:30

Задача 3. Написать программу, определяющую, лежит ли точка с

указанными координатами А (x, y) на окружности радиуса R с центром в начале

координат (может лежать на окружности, внутри окружности, вне окружности)

PS: Pascal (не турбо)

Всем буду благодарен!

+2
Ответы (1)
  1. 26 февраля, 17:55
    0
    Var

    x, y, r: Iinteger;

    Begin

    Write ('Введите координату X: ') ;

    Readln (x) ;

    Write ('Введите координату Y: ') ;

    Readln (y) ;

    Write ('Введите длину радиуса R: ') ;

    Readln®;

    If (sqr (x) + sqr (y)) = r then writeln ('Точка лежит на окружности!')

    Else writeln ('Точка не лежит на окружности!') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы