Задать вопрос
1 ноября, 13:31

Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.

Входные данные:

Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D < = 1000).

Выходные данные:

Вывести единственное число.

Пример входного файла (input. txt) :

10 1 1 2 3

Пример выходного файла (output. txt) :

14

+2
Ответы (1)
  1. 1 ноября, 14:45
    0
    var

    n, a, b, c, d: real;

    begin

    try

    assign (input, 'input. txt') ;

    assign (output, 'output. txt') ;

    reset (input) ;

    rewrite (output) ;

    read (input, n, a, b, c, d) ;

    write (output, trunc (a * b * 2 * n * c / d) + 1) ;

    finally

    try

    close (input) ;

    close (output) ;

    except

    end;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы