Задать вопрос
18 июля, 12:59

Решить в паскале:

Написать программу решения квадратного уравнения

+4
Ответы (1)
  1. 18 июля, 16:45
    0
    Program QuadraticEquation;

    Var a, b, c, d, x1, x2:real;

    Begin

    Writeln ('vvedite a, b, c') ;

    Readln (a, b, c) ;

    If A=0 then

    Writeln ('algoritm ne primenim') ;

    D:=b*b-4*a*c;

    If D<0 then

    Writeln ('deystvit resheniy net') ;

    If D=0 then

    Begin

    x1:=-b / (2*a) ;

    Writeln ('x1=', x1) ;

    End

    Else

    Begin

    x1: = (-b+sqrt (D)) / (2*a) ;

    x2: = (-b-sqrt (D)) / (2*a) ;

    Writeln ('x1=', x1, 'x2=', x2) ;

    End;

    end.

    Держи!)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить в паскале: Написать программу решения квадратного уравнения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы