Задать вопрос
22 июня, 20:51

Каждая бактерия делится на 2 через каждые 3 минуты. В начальный момент имеется 1 бактерия. Сколько их будет через n минут. N вводится пользователем. Составить программу с помощью цикла со счётчиком. (For счётчик:=нач. значение to конечное значение do)

+2
Ответы (1)
  1. 22 июня, 21:04
    0
    var n, i : integer;

    b : real;

    begin

    readln (n) ;

    b:=1;

    for i:=1 to n div 2 do

    begin

    B:=B*2;

    end;

    writeln (b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Каждая бактерия делится на 2 через каждые 3 минуты. В начальный момент имеется 1 бактерия. Сколько их будет через n минут. N вводится ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы