Задать вопрос
2 июля, 21:47

Помогите прошу.

Составить программу, которая вводит с клавиатуры любое число от 150 до 255, и выводит символ, соответствующий этому коду.

+5
Ответы (1)
  1. 3 июля, 01:30
    0
    Формула для рандома:

    : = Random (b-a+1) + a,

    где:

    a - начальное значение диапазона;

    b - конечное значение диапазона.

    chr - в озвращает символ с определённым номером.

    var

    x: byte;

    begin

    randomize;

    x:=random (255-150+1) + 150;

    writeln ('Число: ', x) ;

    writeln ('Символ: ', chr (x)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите прошу. Составить программу, которая вводит с клавиатуры любое число от 150 до 255, и выводит символ, соответствующий этому коду. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы