Задать вопрос
17 ноября, 07:58

Помогите решить две задичи

Задача: Написать программу, которая

а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран

б) удаляет все буквы 'а' из строки и выводит новую строку на экран

+2
Ответы (1)
  1. 17 ноября, 10:06
    0
    Var st:string;

    i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (st) ;

    for i:=1 to length (st) do begin

    if st[i]='a' then

    st[i]:='o';

    end;

    writeln (st) ;

    end.

    var st:string;

    i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (st) ;

    for i:=1 to length (st) do begin

    if st[i]='a' then

    delete (st, i, 1) ;

    end;

    writeln (st) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы