Задать вопрос
11 января, 18:50

1) Вычислить сумму четных и нечетных элементов (также в массиве).

2) Вычислить количество "0" в массиве.

Написать программу в Pascal.

P. S.: можно сделать одну задачу из двух.

+2
Ответы (1)
  1. 11 января, 19:06
    0
    Program sum_nechet;

    var a: array [0 ... 100] of integer;

    var b, i, c, k:integer;

    begin

    randomize;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) ;

    writeln (a[i]) ; / / Это можно не писать, просто чтобы видеть числа в массиве, если интересно.

    end;

    c : = 0;

    b : = 0;

    for i:=1 to 10 do

    begin

    if a[i] mod 2 = 0 then

    b : = b + a[i]

    else

    c : = c + a[i];

    end;

    writeln ('Нечетных ', c) ;

    writeln ('Четных ', b) ;

    k:=0;

    for i:=1 to 10 do

    begin

    if a[i] = 0 then

    k: = k+1

    end;

    writeln ('Нулей ', k)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Вычислить сумму четных и нечетных элементов (также в массиве). 2) Вычислить количество "0" в массиве. Написать программу в Pascal. P. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы