Задать вопрос
7 января, 12:32

Составить функцию нахождения объема шара, зная его радиус. С помощью данной функции вычислить объем для N шаров.

Pascal ABC

Написать программу с помощью процедур и функций.

+1
Ответы (1)
  1. 7 января, 13:31
    0
    Function ob (r:real) : real;

    var v:real;

    begin

    v:=4/3*r*r*r*pi;

    ob:=v;

    end;

    var n, i:integer;

    v1, r1:real;

    begin

    readln (n) ;

    for i:=1 to n do

    begin

    write ('Введите радиус ', i,'-го шара: ') ;

    readln (r1) ;

    v1:=ob (r1) ;

    writeln ('Объем шара: ', v1) ;

    writeln;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить функцию нахождения объема шара, зная его радиус. С помощью данной функции вычислить объем для N шаров. Pascal ABC Написать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы