Задать вопрос
22 июня, 07:42

Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве. Массив также должен вводится во время программы.

+5
Ответы (1)
  1. 22 июня, 08:57
    0
    Const

    max = 10; / / Количество элементов в массиве

    var

    a:array [1 ... max]

    i, m:integer;

    begin

    write ('Введите', max,'чисел') ;

    for i:=1 to max do

    read (a[i])

    write ('Введите число') ;

    read (m) ;

    for i:=1 to max do

    begin

    if a[i] = m

    then

    begin

    write ('Это число есть в массиве') ;

    exit

    end;

    end;

    write ('Этого числа нет в массиве')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве. Массив также должен вводится во время программы. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Написать программу в среде Delphi, которая проверяет находится ли введённое с клавиатуры число в массиве.
Ответы (1)
Всё сделать в программе PascalABC Задача №1 С клавиатуры вводится число n. Заполнить n элементов массива числами 2,4,8,16 ... и вывести массив. В массиве может находить не более 100 элементов. Задача №2 С клавиатуры вводится число n.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)