Задать вопрос
25 июля, 04:30

Помогите написать программу в паскале.

Задано натуральное число n. Вычислить произведение цифр заданного числа.

+1
Ответы (1)
  1. 25 июля, 07:52
    0
    Var

    n, i, p: integer;

    begin

    p : = 1;

    read (n) ;

    while n > 0 do

    begin

    p : = p * (n mod 10) ;

    n : = n div 10;

    end;

    write (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в паскале. Задано натуральное число n. Вычислить произведение цифр заданного числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы