Задать вопрос
24 апреля, 11:40

Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова.

Написать программу в Pascal.

+5
Ответы (1)
  1. 24 апреля, 11:45
    0
    Var a, b, c:integer;

    p, n:string;

    begin

    readln (p)

    ; For a:=1 to length (p) do

    begin

    n:=copy (p, a, 1) ;

    If (n=' ') or (n=',') then

    begin

    If b>c then c:=b;

    b:=0

    end

    else

    b:=b+1;

    end;

    If c=0 then c:=b;

    writeln (c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова. Написать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы