Задать вопрос
9 августа, 11:04

Написать программу вычисления суммы кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных 3 (2 способа: for, while)

+1
Ответы (1)
  1. 9 августа, 11:45
    0
    var

    i, s, p : integer;

    begin

    write ('n=') ;

    readln (n) ;

    s:=0;

    p:=1;

    for i:=1 to n do

    begin

    if i mod 5=0 then s:=s+i;

    if i mod 3=0 then p:=p*i

    end;

    Writeln ('s=', s, ' p=', p)

    end.

    2)

    var

    i, s, p : integer;

    begin

    write ('n=') ;

    readln (n) ;

    s:=0;

    p:=1;

    i:=1

    while i< = n do

    begin

    if i mod 5=0 then s:=s+i;

    if i mod 3=0 then p:=p*i;

    i:=i + 1;

    end;

    Writeln ('s=', s, ' p=', p)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу вычисления суммы кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных 3 (2 способа: for, while) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы