Задать вопрос
6 января, 06:44

Составьте

программу вычисления в массиве B (N)

минимального среди положительных

элементов и его номера

+3
Ответы (2)
  1. 6 января, 09:52
    0
    Const N=10;

    var a: array [0 ... N] of integer;

    i, m: integer;

    begin

    for i : = 0 to N do

    a[i] : = random (1000) - 500; { Надо же что-то в массив закинуть =) }

    for i : = 0 to N do

    if ((a[i] > 0) and (a[i] > a[m])) then

    m : = i;

    writeln ('[', m, '] = > ', a[m]) ;

    end.
  2. 6 января, 10:09
    0
    Min:=b[1];

    max:=b[1];

    for i:=1 to n do begin

    if min
    min:=b[i];

    if max>b[i] then

    max:=b[i];

    max:=b[i];

    end;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу вычисления в массиве B (N) минимального среди положительных элементов и его номера ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы