Задать вопрос
18 августа, 11:52

Нужно составить программу ветвления по информатике! Для задачи:

На приеме у педиатра производится измерение роста и всеса грудных детей в возрасте до трех месяцев. Компьютер определить рост и вес месяц назад.

Рост и вес ребенка в день приема, если ребенок на три сантиметра вырос и более, а вес увеличился на 700 грамм и более выдается сообщениие, что развивается хорошо, если прибавил меньше трех сантиметров или вес меньше чем на 700 грамм, выдается сообщение ребенок меньше нормы

+4
Ответы (1)
  1. 18 августа, 11:58
    0
    Решение на Pascal (если не подходит - скажите) :

    program pediatr;

    var

    h_old, h_new, w_old, w_new: integer;

    begin

    write ('введите рост ребёнка месяц назад (в см) : ') ;

    readln (h_old) ;

    write ('введите рост ребёнка сейчас (в см) : ') ;

    readln (h_new) ;

    write ('введите вес ребёнка месяц назад (в г) : ') ;

    readln (w_old) ;

    write ('введите рост ребёнка сейчас (в г) : ') ;

    readln (w_new) ;

    if ((h_new - h_old) > = 3) and ((w_new - w_old) > = 700) then

    writeln ('Ваш ребёнок развивается хорошо')

    else

    writeln ('Ваш ребёнок меньше нормы') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно составить программу ветвления по информатике! Для задачи: На приеме у педиатра производится измерение роста и всеса грудных детей в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы