Задать вопрос
1 марта, 19:51

Это в Паскале.

Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел.

И вторая: Дана последовательность чисел, количество которых заранее не известно. Сколько чисел было введено до первого нуля?

Буду очень благодарен, если ответите.

+3
Ответы (1)
  1. 1 марта, 21:02
    0
    {1}

    var

    i, n, s: integer;

    begin

    i : = 0;

    writeln ('Введите последовательность чисел, оканчивающихся отрицательным числом') ;

    repeat

    readln (n) ;

    if n > 0 then begin

    s : = s + n;

    i : = i + 1;

    end;

    until n < 0;

    writeln (s / i) ;

    end.

    {2}

    var

    i, n: integer;

    begin

    i : = 0;

    writeln ('Введите последовательность чисел, оканчивающихся 0') ;

    repeat

    readln (n) ;

    if n 0 then

    i : = i + 1;

    until n = 0;

    writeln (i) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы