Задать вопрос
15 июня, 07:28

Напишите программу в двухмерном массиве 6*3 для каждой нечетной строки определить произведение положительных элементов

+5
Ответы (1)
  1. 15 июня, 07:46
    0
    Var

    arr:array[1 ... 6,1 ... 3] of integer;

    i, j:integer;

    p:longint;

    begin

    randomize;

    p:=1;

    for i:=1 to 6 do

    begin

    for j:=1 to 3 do

    begin

    arr[i, j]:=random (10) ;

    write (arr[i, j]:5) ;

    end;

    writeln;

    end;

    for i:=1 to 6 do

    begin

    if i mod 20 then

    begin

    for j:=1 to 3 do

    if arr[i, j]>0 then p:=p*arr[i, j];

    end;

    end;

    writeln ('Произведение положительных элементов нечетных строк: ', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в двухмерном массиве 6*3 для каждой нечетной строки определить произведение положительных элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы