Задать вопрос
1 марта, 17:23

Помогите составить программу, которая организует ввод массива a[1 ... 10] с клавиатуры, затем преобразовывает массив, заменяя все отрицательные элементы их модулями.

+2
Ответы (1)
  1. 1 марта, 18:08
    0
    Var ar:array[1 ... 10] of integer;

    i:integer;

    begin;

    for i:=1 to 10 do

    begin;

    write ('Введите ', i,' элемент массива:') ;

    readln (ar[i]) ;

    if ar[i]<0 then ar[i]:=abs (ar[i]) ;

    end;

    writeln ('Final array:') ;

    for i:=1 to 10 do

    write (ar[i]:4) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу, которая организует ввод массива a[1 ... 10] с клавиатуры, затем преобразовывает массив, заменяя все ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы