Задать вопрос
23 сентября, 23:18

Помогите написать программу на паскале

Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от - 10000 до 10000 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, сумма которых четна и положительна. Под парой подразумевается два подряд идущих элемента массива.

+5
Ответы (1)
  1. 23 сентября, 23:51
    0
    Program gt;

    var a:array[1 ... 20]of longint;

    i, h:longint;

    begin

    for i:=1 to 20 do

    read (a[i]) ;

    for i:=1 to 19 do

    if ((a[i]+a[i+1]>0) and ((a[i]+a[i+1]) mod 2=0)) then h:=h+1;

    writeln (h) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на паскале Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от - 10000 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы