Задать вопрос
15 апреля, 10:48

дано целое двузначное число. Составить программу которая определяет входит ли в него цифра 4

+5
Ответы (2)
  1. 15 апреля, 11:29
    0
    На псевдокоде

    Алг (a, b, fl)

    Арг a, b

    Рез fl

    ввод (a; b) {где а-это десятки, b-еденицы}

    fl:=true

    Если (a=4) или (b=4) то fl:=true все

    Если fl=true то вывод ('есть') иначе вывод ('нету')

    конец
  2. 15 апреля, 11:42
    0
    var

    a:byte;

    begin

    write ('Введите число ') ; readln (a) ;

    if (a div 10 = 4) or (a mod 10 = 4) then

    writeln ('В число входит цифра 4')

    else

    writeln ('цифра 4 в число не входит') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «дано целое двузначное число. Составить программу которая определяет входит ли в него цифра 4 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы