Задать вопрос
29 июня, 22:51

Составить программу в паскале

Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.

+1
Ответы (1)
  1. 30 июня, 02:37
    0
    Var n:longint;

    c:real;

    begin

    write ('N = ') ;

    readln (n) ;

    if (n mod 2 = 0) and (n>0) then c:=n/4 else

    if (n mod 2 = 0) and (n<0) then c:=n*5 else

    if (n mod = 1) then c:=sqr (n) ;

    write (c:0:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы