Задать вопрос
7 февраля, 21:44

1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали. Выведите на экран исходный и измененный массивы (программа на языке Паскаля)

2) Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

+1
Ответы (1)
  1. 7 февраля, 22:31
    0
    Var a: array [1 ... 5, 1 ... 5] of integer;

    i, m, j: integer;

    begin

    for i : = 1 to 5 do

    for j : = 1 to 5 do

    begin

    a[i, j] : = random (50) - 25;

    writeln ('[', i, ',', j, '] = > ', a[i, j]) ;

    end;

    for i : = 1 to 5 do

    for j : = 1 to 5 do

    if (a[i, j] mod 2 = 0) then a[i, j] : = 30;

    writeln () ;

    for i : = 1 to 5 do

    for j : = 1 to 5 do

    writeln ('[', i, ',', j, '] = > ', a[i, j]) ;

    end.

    Для второго не понял, как решать._.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением.
Ответы (1)
Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали двумерного массива, заданного с помощью датчика случайных чисел. (Паскаль абс) С объяснением.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все нечетные элементы с четными индексами на нули. Выведите на экран исходный и полученный массивы. 2. Задайте массив из 10 элементов с помощью датчика случайных чисел.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Помогите решить. Напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки.
Ответы (1)