Задать вопрос
12 марта, 17:27

С клавиатуры вводится трехзначное число. Составьте программу выводящую сумму его чисел.

+2
Ответы (1)
  1. 12 марта, 18:00
    0
    var

    a, s: integer; / / целочисленный тип данных

    begin

    writeln ('Введите число:') ;

    readln (a) ; / / вводим число (можно больше трех знаков)

    while a 0 do / / пока остались цифры в числе выполнять ...

    begin

    s : = s + (a mod 10) ; / / Отбираем последнюю цифру числа и прибавляем к сумме

    a : = a div 10; / / Стираем последнюю цифру числа

    end;

    writeln ('Сумма цифр = ', s) / / выводим результат

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводится трехзначное число. Составьте программу выводящую сумму его чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы