Задать вопрос
11 сентября, 23:45

Паскаль абс

Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь находится в координате z. Определите, какая из кошек первой доберется до мыши, если кошки передвигаются с одной скоростью. В случае если кошки одновременно добираются до мышки, то тогда кошки ссорятся из-за добычи, и мышь ускользает от них. Формат входных данных Единственная строка входного файла содержит три целых числа x, y, z (1 < = x, y, z < = 1 000). Все числа различны. Формат выходных данных Если первая кошка доберется до мышки раньше второй выведите "1" (без кавычек). В случае если вторая кошка доберется до мыши раньше первой выведите "2" (без кавычек). В случае если мышка ускользает выведите "3" (без кавычек).

+3
Ответы (1)
  1. 12 сентября, 03:00
    0
    Var x, y, z:integer;

    begin

    readln (x, y, z) ;

    if abs (x-z)
    then writeln (1)

    else if abs (x-z) >abs (y-z)

    then writeln (2) else writeln (3) ;

    end.

    Пример: 2 8 4

    1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль абс Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы