Задать вопрос
4 мая, 12:37

Напишите программу для записи четырехзначного числа в обратном порядке.

Например:

2451-->1542

Паскаль.

+4
Ответы (1)
  1. 4 мая, 15:15
    0
    Var n, m: integer;

    begin

    write ('n = ') ; readln (n) ;

    m:=0;

    repeat

    m:=m*10 + (n mod 10) ;

    n:=n div 10;

    until n=0;

    writeln (m) ;

    end.

    n = 2456

    6542
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу для записи четырехзначного числа в обратном порядке. Например: 2451-->1542 Паскаль. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы