Задать вопрос
6 мая, 11:13

Составьте программу которая находит сумму четных чисел в и произведение нечетных чисел в диапазоне от 1 до 10

+2
Ответы (1)
  1. 6 мая, 11:47
    0
    Var i, a, s, s2:integer;

    begin

    s:=0;

    s2:=1;

    for i:=1 to 10 do

    begin

    if (i mod 2=0) then s:=s+i;

    if (i mod 2=1) then s2:=s2*i;

    end;

    inc (i) ;

    writeln ('Сумма четных ', s) ;

    writeln ('Произведение нечетных ', s2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу которая находит сумму четных чисел в и произведение нечетных чисел в диапазоне от 1 до 10 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Составьте программу которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10
Ответы (1)
Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10. в PascalABC
Ответы (2)