Задать вопрос
28 марта, 12:58

Сколько существует "счастливых" четырехзначных билетов? "Счастливым" считается билет, у которого сумма первых двух цифр равна сумме двух последних.

+3
Ответы (1)
  1. 28 марта, 15:58
    0
    615 чисел.

    Вот программа на Паскале ABC по их вычислению:

    Program bilet;

    var i:integer;

    s:string;

    begin

    for i:=1000 to 9999 do begin

    s:=IntToStr (i) ;

    if StrToInt (s[1]) + StrToInt (s[2]) = StrToInt (s[3]) + StrToInt (s[4]) then writeln (i) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сколько существует "счастливых" четырехзначных билетов? "Счастливым" считается билет, у которого сумма первых двух цифр равна сумме двух ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы