Задать вопрос
18 января, 03:14

4. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 40.

var x, L, M: integer;

begin

readln (x) ;

L : = x-10;

M : = x+30;

while L M do

if L > M then

L : = L - M

else

M : = M - L;

writeln (M) ;

end.

+4
Ответы (1)
  1. 18 января, 03:47
    0
    Label metka;

    var x, L, M: integer;

    begin

    for var i:=100 to 300 do

    begin

    x:=i

    ; L : = x-10;

    M : = x+30;

    while L M do

    if L > M then

    L : = L - M

    else

    M : = M - L;

    If (M=40) then

    begin

    Println (x) ;

    goto metka;

    end;

    end;

    metka:

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «4. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 40. var x, L, M: ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы