Задать вопрос
20 февраля, 14:46

Составить программу на языке pascal. используя цикл repeat ... until.

Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.

+5
Ответы (1)
  1. 20 февраля, 14:51
    0
    var

    a, min: integer;

    begin

    min : = 1000;

    repeat

    readln (a) ;

    if (a = 0) then min : = a;

    until (a < 0) ;

    writeln ('Минимальное число: ', min) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на языке pascal. используя цикл repeat ... until. Определить минимальное число из введенной с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности не ограничена) Программа Паскаль Цикл с пост условием
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
напишите программу на языке паскаля через цикл while, которая определяет максимальное из введенных чисел с клавиатуры (ввод чисел заканчивается числом 0).
Ответы (1)